The Place for Mystery Since 1995
MysteryNet Home
TV Movies

Buy through our affiliates:
•  Mystery Guild Book Club
•  Buy Books
•  Buy Games

Using Discussion

Registering (FREE—required to post)

• Subscribe   • Edit Posts   • Personal Profile

Customization & Tools (For Members)

 [F] Mystery Net Community  / Games & Puzzles  / Clue Chronicles  /

Fatal Illusion: CD-ROM
Clue Chronicles
Join your favorite Clue characters in 2 all new adventures

You've been invited to a very special New Year's Eve party. Join your favorite characters from Clue-- and a few surprising new ones-- at the bizarre castle stronghold of reclusive millionaire, Ian Masque. Unravel a murder set in a shadowy world of politics, wealth, and the supernatural. Discuss Episode 1 of the Clue Chronicles Mystery Series with fans and visitors here! Fatal Illusion: The new interactive mystery adventure CD-ROM from Clue.
Please Note: Anyone looking for help: Many of the same questions have been asked and answered in this discussion. Before posting about where you are stuck, please use the Search Button and type in the key words - such as "cable car". This should bring up a list of every post where the cable car is mentioned. Your answer may already be here.

The patch for this game is still available. Hasbro Interactive was taken over by another company in 2001. You can get it at: this link. Thanks ~Fran

Previous MessagesEarliest MessagesOutlineRecent Messages More Messages (4044 previous messages)
Becci O - 04:29pm Jul 20, 2005 PST(#4045 of 4060)

Can anyone help?? Ive been stuck with the lock combination for ages and have tried the hints on here but it still wont work! i know combination is 12 31 38 and seen help on here saying go to left for 12, right for 31 and left for 38 but does that mean anti-clockwise for 12 clockwise for 31 and anticlockwise for 38? Sorry if im being thick just tried so many thing!! Please someone help its driving me insane!! :o)

I have been stuck with the combination lock for months, on finding this site I thought I would try again, nothing suggested worked, until in desperation I went left to 12, right to 31 and left to 38 and to my surprise the door opened.

Lisa Haines - 02:39pm Aug 28, 2005 PST(#4046 of 4060)

Help stuck on the lock. I have tried going left to 12 right to 31 and left to 38 and it still won't let me in. please help me it's driving me nuts, Arggh

George Lewis - 02:07pm Aug 29, 2005 PST(#4047 of 4060)

Ok - I have read through the whole list of posts here but still can't find the answer to getting Plum's jewel. I've hypnotised him, put the blades in the star shape and nothing happens!!! Please help as I am now going insane!!!

George Lewis - 02:29pm Aug 29, 2005 PST(#4048 of 4060)

Ok - ignore my last post. I just read through about 2000 posts until I found Skirvin give the correct combo to make the star!!!!

Skirvin - you are a star!!!!

Fiona Warmerdam - 12:29am Oct 4, 2005 PST(#4049 of 4060)

The door opens if you turn right and pass 31 two times and leave it at 31 the third time. Then turn left and pass 12 once, stop on it the second time. Then turn right to 38 and stop. Click on the handle now. This opened the door for me.

Tera Krizon - 01:09pm Oct 16, 2005 PST(#4050 of 4060)

How do you go about getting the caldenar trick from Urfe. Is it early in the game on the shop or is is once we are at the mansion. Please help. I have all but one jewel to go and it is very annoying.

Tera Krizon - 01:10pm Oct 16, 2005 PST(#4051 of 4060)

I meant ship not shop

Perfect_princess - 02:24am Oct 22, 2005 PST(#4052 of 4060)

how do u get past the iron maiden did the star puzzle thing but when i click on the thing i get a messaye saying i need to learn more about this before i fiddle with it or something like that please help do i need to do anything and when i click in the middle it just resets it please help xoxox love the princess

laura mcfarlane - 04:43am Nov 14, 2005 PST(#4053 of 4060)

really stuck i have all the jewels for all the characters except mustard's i haven't got a trick to show sabata so cannot get a drawing any suggestions?

Ron Shelley - 10:04pm Nov 14, 2005 PST(#4054 of 4060)

HELP! I seem to have lost the pendant when I tried to hypnotize Kell. Where did it go? I went back to the statue to get it but it wasn't there. Can anyone help? Also, how does this hypnosis thing work? I have tried to hypnotize plum and kell, but it didn't work. My game just froze and I had to restart from my saved game.

Ron Shelley - 10:11pm Nov 14, 2005 PST(#4055 of 4060)

Laura, Go to Urfe and he will show you a new trick, then go to Sabata and do the trick on him and he will give you the drawing. Mustard's jewel is in the clock with all the lions around it. Hope this helps, RON.

Sarina Haarsma - 09:08am Jan 17, 2006 PST(#4056 of 4060)

Hello for anywone that can't hypnotise someone.You must just move the pendant quickly back and forth.Then is the person sleepy and can you tell him questions.

Kirsten Neadeau - 11:02am Jan 22, 2006 PST(#4057 of 4060)

I've gotten into the captain's room, but can't seem to put the cog into him to fix him. What do I do?

Earliest MessagesOutlineRecent MessagesMore Messages (3 following messages)

 Read Subscriptions  Search  New User Registration  Login

 [F] Mystery Net Community  / Games & Puzzles  / Clue Chronicles  / Fatal Illusion: CD-ROM

In Association with

Support MysteryNet

Start Your Amazon
Shopping Here: