The Place for Mystery Since 1995
MysteryNet Home
TV Movies

Buy through our affiliates:
•  Mystery Guild Book Club
•  Buy Books
•  Buy Games

Using Discussion

Registering (FREE—required to post)

• Subscribe   • Edit Posts   • Personal Profile

Customization & Tools (For Members)

 [F] Mystery Net Community  / Games & Puzzles  / Clue Chronicles  /

Fatal Illusion: CD-ROM
Clue Chronicles
Join your favorite Clue characters in 2 all new adventures

You've been invited to a very special New Year's Eve party. Join your favorite characters from Clue-- and a few surprising new ones-- at the bizarre castle stronghold of reclusive millionaire, Ian Masque. Unravel a murder set in a shadowy world of politics, wealth, and the supernatural. Discuss Episode 1 of the Clue Chronicles Mystery Series with fans and visitors here! Fatal Illusion: The new interactive mystery adventure CD-ROM from Clue.
Please Note: Anyone looking for help: Many of the same questions have been asked and answered in this discussion. Before posting about where you are stuck, please use the Search Button and type in the key words - such as "cable car". This should bring up a list of every post where the cable car is mentioned. Your answer may already be here.

The patch for this game is still available. Hasbro Interactive was taken over by another company in 2001. You can get it at: this link. Thanks ~Fran

Previous MessagesEarliest MessagesOutlineRecent Messages More Messages (122 previous messages)
Jayne - 08:22pm Nov 22, 1999 PST(#123 of 4060)

Help! I'm completely baffled. I have tried everything I can think of but don't have a clue (bad joke) on where the gas goes in on the cable car. The buttons I think I know from the instructions, but where is the fuel tank for the kerosene? Assist is appreciated.

Jeffrey Hitchin - 09:26pm Nov 22, 1999 PST(#124 of 4060)

LM: The pendant is in the artifact room with the lion. Stand where you would talk to Professor Plum and turn left. In order for Scarlet to tell you her riddle, you have to show her something first. You can find this in the dining room. Walk forward from where you would talk to Mr. Green and look around. Let me know if you need a more direct hint.

Jayne: When you walk into the station at the base of the mountain, go forward, turn left, and you should see a couple of small cabinets off to the side. Open one, and you should get the can of gas and the funnel. Go back and stand in front of the door, but don't go through it. Turn left. Use the funnel on the tank, use the kerosene can on the tank. That should refuel it. Let me know if you need more help.

t m - 10:54pm Nov 22, 1999 PST(#125 of 4060)

Every time I load a game, my computer freezes. Does anyone else have this problem? Do have any suggestions? please help me if you can!

Jamie Lee - 02:03am Nov 23, 1999 PST(#126 of 4060)

Help! I can't get the door open that is at the top of the stairs (of the ship). It is the door with the captain's wheel on it, and I don't know how to get it open! White has given me a hint already, what else am I missing?

Anjell Meyers - 10:27am Nov 23, 1999 PST(#127 of 4060)

My pendant is gone!! I tried using it once, and then it was gone from my inventory. What do I do now?

SN - 03:23pm Nov 23, 1999 PST(#128 of 4060)

Jamie - To open the door at the top of the stairs, you need to open the puzzle box and get the crank. hope this helps.

Jeffrey Hitchin - 05:16pm Nov 23, 1999 PST(#129 of 4060)

Anjell: If you've already gotten Plum's riddle out of him by using the pendant, then you really don't need it again and shouldn't worry. If you haven't gotten it yet, then it's a bug and you should contact techcnical support.

Jayne - 05:29pm Nov 23, 1999 PST(#130 of 4060)

Jeffrey H---Thanks much for the assist, I was pulling out a few hairs.

L M MOORE - 06:33pm Nov 23, 1999 PST(#131 of 4060)

Skirvin...Thanks for your help It just takes a few trys, but like you said, keep trying.

Jeffrey H.....Thank you for your input, I'll try your hints and see when I play tonight.

To all of you who have posted here, I can't tell you how impressed I am with all the help, hints, and serious players. I have had other game chat sights and they were not worth reading. This site makes the game fun, even when the game freezes up. It forces you to re-load and try again and make it last a little longer. Thank you all again.

Charles Barnett - 06:36pm Nov 23, 1999 PST(#132 of 4060)

I can't get the Ouiji board to work. It pops up and I move the pointer over the letters of the last name of the deceased characters and nothing happens. I even tried Ian Masque. Please help.

sn - 06:46pm Nov 23, 1999 PST(#133 of 4060)

charles - you need to spell out the last names of the people attending the seance - including popov.

Charles Barnett - 08:02pm Nov 23, 1999 PST(#134 of 4060)

Thanks for the help. I got through the Ouiji board...I wish that weren't part of the game though. Now I made it through the catacombs after getting the jewels, but I can't figure out where to put them on that coffin looking thing.

L M MOORE - 08:32pm Nov 23, 1999 PST(#135 of 4060)

Do you move the mouse to get the pendant swinging? Also, Why is there no jewel in the lion? I have clicked on EYES, LEGS, NOSE, EARS, everything falls off but, now what?

Earliest MessagesOutlineRecent MessagesMore Messages (3925 following messages)

 Read Subscriptions  Search  New User Registration  Login

 [F] Mystery Net Community  / Games & Puzzles  / Clue Chronicles  / Fatal Illusion: CD-ROM

In Association with

Support MysteryNet

Start Your Amazon
Shopping Here: