The Place for Mystery Since 1995
MysteryNet Home
TV Movies

Buy through our affiliates:
•  Mystery Guild Book Club
•  Buy Books
•  Buy Games

Using Discussion

Registering (FREE—required to post)

• Subscribe   • Edit Posts   • Personal Profile

Customization & Tools (For Members)

 [F] Mystery Net Community  / Games & Puzzles  / Clue Chronicles  /

Fatal Illusion: CD-ROM
Clue Chronicles
Join your favorite Clue characters in 2 all new adventures

You've been invited to a very special New Year's Eve party. Join your favorite characters from Clue-- and a few surprising new ones-- at the bizarre castle stronghold of reclusive millionaire, Ian Masque. Unravel a murder set in a shadowy world of politics, wealth, and the supernatural. Discuss Episode 1 of the Clue Chronicles Mystery Series with fans and visitors here! Fatal Illusion: The new interactive mystery adventure CD-ROM from Clue.
Please Note: Anyone looking for help: Many of the same questions have been asked and answered in this discussion. Before posting about where you are stuck, please use the Search Button and type in the key words - such as "cable car". This should bring up a list of every post where the cable car is mentioned. Your answer may already be here.

The patch for this game is still available. Hasbro Interactive was taken over by another company in 2001. You can get it at: this link. Thanks ~Fran

Previous MessagesEarliest MessagesOutlineRecent Messages More Messages (191 previous messages)
Jennifer Reposh - 03:10pm Nov 30, 1999 PST(#192 of 4060)

I have tried to hypnotize Kell, but my pendant keeps disappearing. That is why I went to Plum. Do I need to have the pendant in front of his face or off to the side? I can get it swinging, but nothing happens, that is why I want to know where I should have the pendant. THANKS!!!!!!!


Christine Z. - 03:53pm Nov 30, 1999 PST(#193 of 4060)

I feel like and idiot. I have been playing for 5 days now and I cannot even get past the beginning. I went into the room with the combination door lock and took the gear and the gloves. I see a hook and a wrench, but I can not seem to pick them up. Also, I go to the top of the stairs but I am unable to open the door. I am totally stuck. I have tried everything I can think of. Someone please tell me what to do before I go nuts. Thanks.

Deborah D - 05:47pm Nov 30, 1999 PST(#194 of 4060)

If you have the gear and the gloves, you still need to get some artifacts which will help you open the puzzle box.

Have you gotten Sabata to draw you a picture yet? If you have, and what was pictured occurred, then take a close look at the debris for those artifacts.

Once you have those, you can use them with the puzzle box to open it up.

Nichole Mancone - 06:00pm Nov 30, 1999 PST(#195 of 4060)

okay...i'm past the boat, but stuck on the mountain...i have the directions, but can't get the motor started (and i filled the tank)

skirvin - 06:47pm Nov 30, 1999 PST(#196 of 4060)

lauren, scarlet should tell you to find somebody....explore past the combo door.

jennifer, i really dont think it matters, but try both, you should be able to hypnotize kell as well.....could be a bug??? i never had that problem. sorry :-(

christine, you will obviously use the gear, do you have your box? what about your artifacts? interview scarlet again....she should tell you to find someone! good luck

nichole, your objective is to get the red light on....once you get it on then go into the cable car to start it. pay particular attention to the drawer in the drawing and the drawer on the control cabinet. good luck

everyone, it is good to interview your people after events happen. (i.e- you add something to inventory) stories change with characters, but not all. if you see you have asked all the questions then move on...but ask any new ones that might show up on the list! have fun!! 8-)

Eben Moore - 07:41pm Nov 30, 1999 PST(#197 of 4060)

Everyone, I finally solved it after four days. Lots of fun!!! I can't wait for the next installment. Don't give up! Eben

Carol Sacks - 10:33pm Nov 30, 1999 PST(#198 of 4060)

I am stuck trying to get into the room on the boat with the pulley type thing on it. How do you get the door open? Did I miss something I need to find? Please help-I have been stuck for days-even went back and talked to all the people again-still nothing. thanks for any help-also are there any walkthrus or hint sites on this game-I can't find any.

Paul Howls - 01:59am Dec 1, 1999 PST(#199 of 4060)

Carol - I think the missing piece of the cog thing is inside the Chinese Puzzle Box. Pick the box up off the floor (hint: Kell tells you not to "touch" the box) and use the artifacts from the urn that white dropped to open it.

Eben - Ditto, I did it in four as well (though I didn't see much of the weekend !) Anyone know when the next is out ?

cynthia flavin - 05:26am Dec 1, 1999 PST(#200 of 4060)

help! i am stuck, been trying now for weeks, cant get the combo to open on door. have tried everything! left and gone on but must do that first! andy help appreciated!

skirvin - 05:59am Dec 1, 1999 PST(#201 of 4060)

cynthia, scarlet should tell you if she "sees" need this to open the door! 8-)

Paul Howls - 06:34am Dec 1, 1999 PST(#202 of 4060)

Lauren - Did you switch the Captain back on again ? Go to the box that you used to switch him off and play with the valves until you get a green light.

Cynthia - in addition to what Skirvin said (this is posted in earlier messages, but I'll repeat it) you have to alternate the directions that you turn the combo lock (once you've got your numbers) and for the first two, you've got to do a full rotation before going to your number.

Earliest MessagesOutlineRecent MessagesMore Messages (3858 following messages)

 Read Subscriptions  Search  New User Registration  Login

 [F] Mystery Net Community  / Games & Puzzles  / Clue Chronicles  / Fatal Illusion: CD-ROM

In Association with

Support MysteryNet

Start Your Amazon
Shopping Here: