Nancy Drew Books | Nancy Drew Games | Nancy Drew Auctions | Knowing Nancy Drew and Carolyn Keene | Discuss Nancy Drew

Nancy Drew Games Buy Nancy Drew Games
Support this website: Buy your games through our affiliation with Amazon. Browse Nancy Drew Games
Nancy Drew Books Buy Nancy Drew Books
Support this website: Buy your books through our affiliation with Amazon. Browse Nancy Drew Books

 [F] Nancy Drew Grownups Discussions  / Nancy Drew Computer Games  /

Treasure in the Royal Tower Computer Game (#4)
Nancy Drew CD-ROM game Treasure in the Royal Tower
"Treasure in the Royal Tower"
Buy through Amazon and support this site!

Stuck some where? Need a tip?

Please read this post before posting a question.


For discussion on this game other than game help, please visit Discuss All Games

Please Note: When giving detailed instructions to players, please begin your post with the words SPOILER ALERT. This will give others a warning the post may contain information they are still working on. PLEASE DO NOT POST THE NAME OF THE VILLIAN!

Previous MessagesEarliest MessagesOutlineRecent Messages More Messages (40 previous messages)
Miss Match - 02:23am Nov 28, 2001 PST(#41 of 18143)

Did you see the circle in the middle of the tower room? The middle thing . . . it's square. And . . .hmm . . .looks like a key hole of some sorts. See if you can get the medallions to fit in the hole around it, then put the key in.

Green Hornet - 02:10pm Nov 28, 2001 PST(#42 of 18143)
Oh, the huge manatee!


Go back to the switch box and flip the two single breaker switches on the right. I went through half the game thinking that the stopped clock was a clue!

Green Hornet - 02:55pm Nov 28, 2001 PST(#43 of 18143)
Oh, the huge manatee!

OK, I'm officialy mad! All the questions are used up. I have all the medallions. I have been to the tower and tried them in differnt combinations half a dozen times. I called Bess and George for a clue and they said "secret decoder...hellllooooo! What are you waiting for?" I tried to retrieve the diary but can only look at the translated sheet and that is no help. WHERE IS THE STUPID SQUARE KEY?

TIffany H. - 05:35pm Nov 28, 2001 PST(#44 of 18143)

I need help how can you climb up the metal ladder when you go through the hole on the elevator roof.......! HELP PLEASE!

Green Hornet - 01:38pm Nov 29, 2001 PST(#45 of 18143)
Oh, the huge manatee!

TIffany H;

Take the elevator to the basement and go through the trap door. Just follow the UP arrows. I find that the DIRECTION ARROWS are a great improovement over past games, don't you?

I found what I was supposed to and got the game going again. I'm going to start it from the beginning WHEN I CALM DOWN!

Anyone else think that Prof. Hotchkiss' video is another swipe at "The Blair Witch Project"?

Tiffany H. - 09:29am Dec 1, 2001 PST(#46 of 18143)

Hey thanks, green hornet.....but i need help again..i can't find a way to fix the machine in the shed, please inform me soon.

Green Hornet - 12:02pm Dec 1, 2001 PST(#47 of 18143)
Oh, the huge manatee!

It's not broken, it operates the ski-lift. Go ahead and try it out if you want, it's helpful later. the diagram is on the work bench, showing the position of the handles.

SuzieQX2 - 09:40pm Dec 1, 2001 PST(#48 of 18143)
People forget what you say and do but they never forget how you make them feel.

Hi everyone...I am totally stuck...i have all the medallions...where is the square key????? going nuts here...please help!!!!!!!

Stephanie Davenport - 03:52pm Dec 4, 2001 PST(#49 of 18143)

I'm stuck at the same point at Green Hornet. I have been over this castle from top to bottom a zillion times now and I can't figure it out. Where is the square key? If there is a square key?!!! I'm still holding the tip of the weapon that I got off the knight infront of the Tower and somehow I think that must be the next step somehow. Any help would be appreciated.

Green Hornet - 06:06pm Dec 4, 2001 PST(#50 of 18143)
Oh, the huge manatee!

A little hint for those who have not gone to the machinery shed, yet.

First thing I did was to go to Nancy's room to get a COAT. Don't bother, can't be done. Click fast and you'll "run" to (Or away from) the shed; this will give you more time to search and you won't freeze to I did!

Green Hornet - 01:12pm Dec 5, 2001 PST(#51 of 18143)
Oh, the huge manatee!

OK! I finnished it! (At last!!!) Here are a couple of clues for the rest of you: In the secret room in the library, you have to click the letter TWICE to read it. This will let you go to the secret garden. The Queen's code is to the LEFT of Hotckiss' typewriter. To read these items SHOULD have been a simple task, but the way it was set up brought the game to a screeching halt. (Are you listening, GAME DESIGNERS?)

I'll start The Final Scene soon. See you then!

Earliest MessagesOutlineRecent MessagesMore Messages (18092 following messages)

 Read Subscriptions  Search  New User Registration  Login

 [F] Nancy Drew Grownups Discussions  / Nancy Drew Computer Games  / Treasure in the Royal Tower Computer Game (#4)